Info for those with Teacher access to the molenet moodle:

February 16, 2009 at 2:58 pm

Hi all

Temi recently had some problems hiding items on the molenet moodle and I’ve been investigating the cause/solution which is proving a bit tricky. It seems if we try to hide, move or edit an item via the little editing icons alongside each item we get a blank screen rather than the editing options or the item being moved. I’ve tracked this down to part of the query string causing the problem e.g. at the end of the url you will see &sr=xy where xy equals a number representing the current topic number. If you remove that end part of the string e.g. &sesskey=aLrm8dUXJG&sr=10 the bit in red here and hit return the edit will work.

However this is obviously not right and I shall investigate further and report back asap.

From some tests I’ve just done the other solution is to enable Ajax on the site and then for you to update your profile to enable this too. This does allow much more efficient organisation of content and blocks but in previous versions of moodle was a little buggy. From my current tests it does seem the best option at the moment until I can get to the bottom of the problem with the normal method of editing so here’s where to go in your profile to switch this on:

 

 

Once you’ve selected [Yes: use advanced web features] click the button to Update Profile. Now when you turn editing on in a course you’ll see little crosses with arrow heads alongside items which you can click and drag to move the item. (see below) You can also click and drag on blocks and topics to move them around so it’s much more efficient to organise things.

 

 

 

Please let me know if this causes you any problems or indeed if you know anything about the cause/solution to the &sr= problem.

UPDATE: How wrong was I about all this! After researching I discovered the cause of the problem was that the site had actually been hacked like many others across the world. It was a long process to get it all sorted and anyone thinking they may have the same issue should read all the info on moodle.org http://moodle.org/mod/forum/discuss.php?d=111710

Posted via email from mitchellmedia’s posterous

Posibly related content: